9. Training Manager

9.1  XE “Overview” Overview

The Training Manager is the interface by which the OASIS Training Server is managed.  The Training Server is an HPUX program that is started by MC/ServiceGuard on the backup FDS (FDS-2).  The Training Server has several states of system operations, INIT being the preliminary state.  The Training Manager functions as a master process that synchronizes and coordinates between the FDS training functions, the WGS training functions, and the WINGS training clients.

The Training Manager sends various requests to control or inquire status from the Training Server.  The messages sent between the Manager and server are of two types: Session Management Request and Training History Data Request.  The Session Management Request Messages deal with commands that change or inquire about the state of the Training Server.  The Training History Data Request Messages are used only when editing the captured scenarios.

The OASIS Training Server has six modes of operation.  Some modes have more than one state.  The states and the associated modes are listed in the table below.


Table 9-1. Training Server Modes and States

	Mode
	State
	State Description

	Idle
	Init
	The Init is the starting and resting point when the Training Server is in the idle mode.  In this state, the Training Server can receive any session management request that starts another mode (i.e., begin capture or begin edit) or a modeless request (i.e., retrieve list or status request).

	Capture
	Recording
	In this state, the Training Server begins the appropriate applications to connect to FDS-1 to receive a copy of the current weather data being received from WMSCR.

	Capture
	Store Recording
	This is a transitional state.  In this state, the Training Server has reached the end of the recording time or has received a stop message from the Training Manager.   The Training Server pre-processes the recorded WMSCR data, packages the data, and stores it in the Training Session Repository (storage disk).

	Edit
	Edit
	In this state, the Training Server receives Training History Data Request messages that allow the Training Manager to view, edit, or delete portions of the recorded WMSCR data.

	Playback
	Load Playback
	In this state, the Training Server retrieves a Training Session from storage and prepares for playback.  Additionally, the Server starts a complete FDS system (excluding certain NADIN interface processes) in the training mode.

	Playback
	Playback
	The recorded training session scenario starts in this state.  The recorded WMSCR data is metered into the system at the same rate that it was received when recorded.  Connection to the simulated FDS system is made via the standard WINGS clients.  To support variable playback times, a simulated system clock is used.

	Playback
	Playback Paused
	In this state, the Training Server is effectively stopped. To emulate stop, the simulated system clock is held up at a fixed time.

	Load Maintenance
	Load Maintenance
	In this state, the Training Server retrieves a Training Session from storage and prepares for maintenance.  Additionally, the Server starts a complete FDS system (excluding certain NADIN interface processes) in the training mode.  

	Maintenance
	Maintenance
	In this state, the Training Manager accepts changes to the system configuration such as adding users.


9.2 Using Training Manager

From the Training Manager window, users perform the following functions:  

· Add Training User’s through the WINGS Training Client Interface

· Capture and store A/N Weather and Graphical data.

· Edit data, scripts, and sessions. 

· Create, edit, and delete flight and weather messages.

· Create, edit and delete training scripts.

· Replay scenarios containing stored A/N and Graphical weather data. 

· Simulate multiple site IDs

· Send time sequence data from multiple scripts.

· Perform maintenance functions.

· View tool and status bars.

· View and manage Training Server events.

· Terminate the Training Manager.

Since the Training Manager can be run from any workstation, the ability to run the application should be limited to administrators and above.  To run the Training Manager, Users must be members of the “OASIS Training” group.  Users can be added to the OASIS Training group using the Active Directory Users and Computers application on the Windows server. 

Once a user has been added to the OASIS Training group, the user may logon to any workstation to display the Training Manager window.  The menu, tool bar and status bar of the Training Manager window are shown in the figure below. 
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Figure 9‑1  Training Manager Window

Training Manager Tool Bar 

Toolbar buttons provide quick access to functions that can also be selected from the Menu bar.  The tooltip labels for these buttons are:  Start Capture, Edit WMSCR Data, Start Replay, Training Script Definition, Edit Flight Message, Edit Weather Message, Start Maintenance Mode, and Event Viewer.

Training Manager Status Bar 

The FDS, DSNT, and SCRIPT panes contain the state of the FDS, DNST, and SCRIPTS.  During the course of a capture the FDS, and DSNT panes would contain the state: RECORDING.  The INJECTION STATE pane states whether or not messages can be injected during the course of a replay.  If the injection is Disabled, messages cannot be injected during the course of a session replay.

9.2.1 Adding Training Users

To add additional users for training purposes it is necessary to utilize the Training Manager and WINGS.  The users that are added must be added while the Training Manager application is in Maintenance mode in order for the users to be permanently added to the training database.

To add Training Manager Users:

1. Once the Training Manager window is displayed, <Select> Maintenance>Start.  The Maintenance Mode dialog box is displayed.  When the Maintenance mode becomes enabled, the End Maintenance Mode button becomes active.
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Figure 9‑2.  Maintenance Mode Message Box
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Figure 9‑3.  Maintenance Mode Enabled Message Box

2. Minimize the Training Manager application window.

3. <Double-Click> the WINGS icon to open the WINGS application. 
4. <Enter> the privileged Username (fdsadmin) and Password. 

5. <Check> the Training Login checkbox.

6. <Click> the OK button to attempt a login.

7. <Select>Status> Assignment>User.

8. <Click> the Add User button. A dialog box will appear asking for the name of the new User

9. <Type> the desired Username and password.

10. <Click> the OK button to create the new user.

11. <Repeat> steps 7-10 to add additional users.

12. <Click> within the table boxes to enable or disable assignments for the Training Users.

13. <Click> the OK button to accept the changes.  The Users Assignment window is closed.

To Create Functional Assignments for Training Users:

1. <Select> Status>Assignment>Functional to display the Functional Assignments window.

2. <Click> within the table boxes to enable or disable assignments for the Training Users.

3. <Click> the OK button to accept the changes.  The Functional Assignment window is closed.

4. Log off WINGS and close the WINGS window. 

5. <Click> the End Maintenance button on the Maintenance Mode dialog box to leave maintenance mode.  The Training Users have been created and will be stored in the Training database.

9.2.2 Capturing  A/N and Graphical Weather Data

The Capture function allows the user to capture A/N and Graphic data from a specific start time to a specific end time.  The user can stop the capture of data prior to the designated end time.  Alphanumeric data is captured automatically.  Graphic data must be manually selected.  

Although the Training Manager application can be run from any workstation, the WIND application will open on the NT Server 2 workstation upon the start of a capture.  The first capture should be done at the NT Server 2 workstation to save the selected products for subsequent captures on another workstation. 

To Save Product Selections for Subsequent Captures

Assuming a capture has been started, <Select> Options>Save User State Now from the WIND menu bar.  The saved product selections will automatically open when WIND is opened on NT Server 2. 

To Initiate the Capture Function:

1. From the Training Manager window, <Click> the Capture menu option.  The Capture pull-down menu is displayed.  

2. <Select> the Start menu option from the pull-down menu.  The Trainer Session Capture Request dialog box is displayed as illustrated below. 
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Figure 9‑4  Session Capture Request Dialog Box


Table 9-2.  Session Capture Request Dialog Box Description

	Label
	Component
	Purpose

	Session Name
	Text Box
	Displays the session name as typed.

	Duration of Capture
	Scroll Boxes
	Displays numbers for selection of hours, minutes, and seconds, indicating the duration of the capture.

	OK
	Button
	Initiates the capture request.


To Capture a Session:

1.
<Enter> the Session Name in the Session Name text box.  The Session Name is displayed.

2.
<Click> and <Hold> the appropriate up and down arrows to set the Duration of Capture.  The numbers scroll for each set of arrows.

3.
<Select> the desired hour(s), minutes, or seconds by releasing the mouse button.   The selected capture time is displayed. 

4.
<Click> the OK button.  The recording is initiated.  The Session Capture Status Dialog box is displayed, as illustrated below.
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Figure 9‑5  Session Capture Status Dialog Box

Table 9-3. Session Capture Status Dialog Box Description

	Label
	Component
	Purpose

	Session ID
	Static Text
	Displays the session name.

	Time Remaining
	Static Text
	Displays the remaining recording time.

	Session Capture Progress 
	Status Bar
	Indicates the percentage of recording time.

	Stop Capture
	Button
	Cancels the capture session.


5.
<Click> the Stop Capture button in the Status dialog box to cancel the capture session without completing the capture.

9.2.3 Editing Data, Scripts and Sessions

The Edit pull-down menu of the Training Manager window, illustrated below, contains the following options:

· WMSCR Data – Edit the WMSCR data.

· Graphical Data – Edit Graphical Weather data.

· Message – Edit a Flight Script message or a Weather Script message.

· Script – Define a training script.

· Session List – Edit the list of captured sessions.
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Figure 9‑6  Edit Drop-Down Window

9.2.3.1 Edit, Add and Delete A/N Weather Data

Captured A/N session data is selected from the WMSCR Data Editor dialog box, illustrated below.  The captured A/N weather data can then be filtered and specific reports can be selected to be retrieved. Once the data has been retrieved then the A/N weather can be modified, added, or deleted using this functionality.

Saving and Committing Changes:

When modifying, adding or deleting A/N weather data for a captured session, it is best to make all modifications at one time, before committing the changes.  Each time the Commit Changes button is selected, the Locator ID’s are renumbered and the modified session data is stored. This can make it difficult to modify session data in multiple steps.
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Figure 9‑7  WMSCR Data Editor Dialog Box

Table 9-4 WMSCR Data Editor Dialog Box Description

	Label
	Component
	Purpose

	Session ID
	Column
	Displays the session name or identification.

	Start Time
	Column
	Displays the session start time.

	Stop Time
	Column
	Displays the recording stop time.

	Number Of Bytes
	Column
	Displays the file size of the recorded session.

	OK
	Button
	Initiates the recording.


To Edit an A/N Weather Data Session

1.
From the Edit pull-down menu, <Click> the WMSCR Data menu option.  The WMSCR Data Editor dialog box is displayed.

2.
<Select> the Session to be edited.  The Session is highlighted.

3.
<Click> the OK button.  The Request WMSCR Data dialog box is displayed as illustrated below.

[image: image11.png]Histowy Type [weather Data Recelved ] Weather Rpts

stine [i1 2 [7 ¢ [0 [0
StopTine [i1 2 [o7 ] 4 [ooo1 | [1506 |

seachsung [
Cancel Help





Figure 9‑8  Request WMSCR Data Dialog Box


Table 9-5 Request WMSCR Data Dialog Box Description

	Label
	Component
	Purpose

	History Type
	Drop-down List Box
	Displays a listing of history request data types.

	Weather Rpts
	Button
	Requests a report type.

	Start Time
	Text Box
	Requests the start date and time the weather data was received.

	Stop Time
	Text Box
	Requests the stop date and time the weather data was received.

	Search String 
	Text Box
	Filter for the history request search string. 

	OK
	Button 
	Initiates the request for WMSCR data.


5.
<Select> the Weather Data Received History Type from the drop-down list box.  The selected type is displayed within the list box.

6.
<Enter> the Start Time and the Stop Time for the time frame of history data to be reconstructed.

7.
<Enter> the Search String to filter the report.

8.
<Click> the Weather Rpts button.  The Report Types dialog box, illustrated below, is displayed.
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Figure 9‑9  Report Types Dialog Box

Table 9-6  Report Types Dialog Box Description

	Label
	Component
	Purpose

	Current Reports
	Check Boxes
	Select to generate reports on METAR, TW, SD, UA, NO, or FDC.

	Warnings
	Check Boxes
	Select to generate reports on WA, WH, WS, WST, or WW.

	Forecasts
	Check Boxes
	Select to generate reports on FA, FD, or TAF.

	Aeronautical
	Check Boxes
	Select to generate reports on ATCSCC or published SUA.

	Active SUA
	Check Boxes
	Select to generate reports on IR, VR, or MOA.

	Other
	Check Boxes
	Select to generate reports on AC, CWA, SYNS, or TWEB.

	Select All
	Toggle Button
	Toggles between Select All and Deselect All.  Select to generate a report on all the weather data.

	OK
	Button
	Initiates the function.


9.
<Select> the check boxes for the data type desired on the report.


OR


<Click> the Select All button to include all weather data.

10.
From the Request WMSCR Data dialog box, <Click> the OK button. 
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Figure 9‑10  Edit WMSCR Data Dialog Box


Table 9-7  Edit WMSCR Data Dialog Box Description

	Label
	Component
	Purpose

	Start Date Time
	Text Box
	Displays the start date and time of the WMSCR data.

	Stop Date Time
	Text Box
	Displays the stop date and time of the WMSCR data.

	Number of Weather Report Types
	Text Box
	Displays the number of weather report types.

	Search String
	Text Box 
	Displays the text entered as search criteria.

	Data Type
	Column
	Displays the data type. Will always be Weather Data Received.

	Timestamp
	Column
	Displays the  timestamp of the WMSCR message.

	Locator ID
	Column
	Displays the Locator ID of the message.

	Summary Data
	Column
	Displays the summary data of the WMSCR message.

	Locator ID
	 Text Box 
	 Displays the locator ID of the message that is being edited.

	Timestamp
	Text Box
	Edit the timestamp of the message.

	Detailed Data
	Text Box
	Edit the necessary fields of the message.

	Control Character Legend
	Legend 
	Defines the symbols used in the text messages.

	Add
	Button
	Adds a WMSCR message with a new locator ID to the session data.

	Delete
	Button
	Deletes a WMSCR message from the session data.

	Save 
	Button
	Saves the modifications to the edited A/N weather message.

	Commit Changes
	Button
	Saves the changes in the Training Server session data.

	Abort Changes
	Button
	Aborts the changes and leaves the session data unchanged.


To Add A/N Weather Data Messages

1. From the Edit WMSCR Data view <Select> an A/N weather message by clicking on the list entry.

2. <Click> the Add button to add a new A/N weather message to the session data.  A message box displays that the message was added.
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Figure 9‑11  Edit WMSCR Data Dialog Box

3. <Click> OK to acknowledge the message box. 

NOTE: The new A/N message is added to the list based on its Timestamp and not it’s Locator ID.  Therefore, the message will appear within the list based on its Timestamp and not necessarily where you would expect it to be based on its numeric Locator ID. 

To Delete an A/N Weather Data Message

1. From the Edit WMSCR Data view <Select> an A/N weather message by clicking on the list entry.

2. <Click> the Delete button to remove a specific A/N weather message from the session data.

To Modify an A/N Weather Data Message

1. From the Edit WMSCR Data view <Select> an A/N weather message by clicking on the list entry.

2. Modify the text of the message as necessary.

3. <Click> the Save button in order for the changes to the message to be saved.

To Commit the A/N Weather Data Changes to Session Data

1. Verify that all changes to the A/N Weather Data have been completed.

2. From the Edit WMSCR Data view <Click> the Commit Changes button.

To Abort the A/N Weather Data Changes to Session Data

1.
From the Edit WMSCR Data view <Click> the Abort Changes button.

9.2.3.2 Creating, Editing, and Deleting Flight and Weather Messages 

Two types of messages are generated from the Training Manager: Flight and Weather Data messages.  The Edit Flight and Weather Data Message functions enable the user to develop new messages and edit existing ones.  These messages can be stored and recalled for later instructor/student interactive transmission or can be included in a message script.  The instructor is allowed to transmit either valid or invalid messages during a training scenario.  The Training Server processes the messages just as if the messages were received over NADIN II.  The messages that have been stored may be selected from the list of existing messages and used in a training script).

Flight Messages

The user edits or deletes flight messages via the Flight Message Edit dialog box, illustrated below.
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Figure 9‑12  Flight Message Edit Dialog Box

Table 9-8  Flight Message Edit Dialog Box Description

	Label
	Component
	Purpose

	Name 
	Text Box
	Displays the message name as entered.

	Flight Message Text
	Text Box or Scroll list
	Displays the message text as typed or displays the existing message text.

	Control character legend
	Legend
	Defines the symbols used in the text message.

	Open
	Button
	Opens an existing message.

	Save
	Button
	Saves the message text.

	Delete
	Button
	Deletes the selected message.


To Create and Save Flight Messages:

1.
From the Edit pull-down menu, <Click> the Message menu option.  The Message cascading menu items are displayed.

2.
<Select> the Flight Message menu option.  The Flight Message Edit dialog box is displayed.

3.
<Select> or <Type> a message name in the Name text box.  The message name is displayed.

4.
<Select> the Flight Message Text box and <Type> the message text.  The message is displayed in the text box with the appropriate control characters.

5.
<Click> the Save button.  The Save Flight Message dialog box is displayed with the File name highlighted in the File name text box. 
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Figure 9‑13  Save Flight Message Dialog Box

Table 9-9 Save Flight Message Dialog Box Description

	Label
	Component
	Purpose

	Save in
	Drop-down List Box
	Selects the desired directory the file is to be saved in.

	Windows Buttons
	Shortcut Buttons 
	Manages drives, directories, files and views (Windows feature).

	Window
	Display Box
	Lists all folders and files contained in the directory listed in Save in.

	File name
	Text Box
	Displays the file name as typed or selected.

	Save as type
	Drop-down List Box
	Selects the desired file extension.

	Save
	Button
	Saves the file in the selected directory.


6.
If the Save Flight Message dialog box has the appropriate settings for Save in, File name, and Save as type, <Click> the Save button.  If not, modify the settings and <Click> the Save button.  The new message file is saved to the selected directory.

To Edit Existing Flight Messages:

1.
From the Edit pull-down menu, <Click> the Message menu option.  The Message cascading menu items are displayed.

2.
<Select> the Flight Message menu option.  The Flight Message Edit dialog box is displayed.  

3.
<Click> the Open button.  The Open Flight Message dialog box, illustrated below, is displayed. 
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Figure 9‑14  Open Flight Message Dialog Box

Table 9-10  Open Flight Message Dialog Box Description

	Label
	Component
	Purpose

	Look in
	Scroll List
	Displays the list of directories

	Windows Buttons 
	Shortcut Buttons 
	Manages drives, directories, files and views (Windows feature).

	Window
	Display Box
	Lists all folders and files contained in the directory listed in Look in.

	File name
	Text Box
	Displays the file name as typed or selected.

	Files of type
	Scroll List
	Displays a list of file types and extensions.

	Open
	Button
	Opens the file in the selected directory.


4.
<Type> a message file name in the File name text box and <Click> the Open button.  The Open Flight Message dialog box is removed and the message is displayed in the Flight Message Edit dialog box.


OR


<Select> a file name from the list of message files and <Click> the Open button.  The Open Flight Message dialog box is removed, and the file name and message text are displayed in the Flight Message Edit dialog box.

5.
To edit the flight message, <Click> in the Flight Message Text field or the Name field and update.  The text is modified.

6.
<Click> the Save button.  The Save Flight Message dialog box is displayed.

7.
<Select> the appropriate settings as necessary and <Click> the Save button. The new message file is saved to the selected directory.

To Delete Flight Messages:

The message that is displayed in the Name text box of the Flight Message Edit dialog box can be deleted.  

1.
<Click> the Delete button.  A Training Manager warning message is displayed.
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Figure 9‑15  Training Manager Warning Message

Table 9-11 Training Manager Warning Message Description

	Label
	Component
	Purpose

	Message
	Static Text
	Questions the continuation of the action listed in the message.

	Yes
	Button
	Continues the action listed in the message.

	No 
	Button
	Cancels the action listed in the message.


2.
<Click> the Yes button to confirm the deletion. 

3.
<Click> the No button to cancel the deletion.

Weather Data

The user edits or deletes weather data messages via the Weather Data Message Edit dialog box.
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Figure 9‑16  Weather Data Edit Dialog Box

Table 9-12  Weather Data Edit Dialog Box Description

	Label
	Component
	Purpose

	Name
	Text Box
	Displays the message name as entered.

	 Weather Data Text
	Text Box or Scroll list
	Displays the message text as typed or  displays the existing message text.

	Control Character Legend
	Legend
	Defines the symbols used in the text messages.

	Open
	Button
	Opens an existing message.

	Save
	Button
	Saves the message text.

	Delete
	Button
	Deletes the selected message.


To Create and Save Weather Data Messages:

1. From the Edit pull-down menu, <Click> the Message menu option.  The Message cascading menu displayed.

2. <Select> the Weather Data menu option.  The Weather Data Edit dialog box is displayed.

3.
<Select> or <Type> message name in the Name text box.  The message name is displayed.

4.
<Select> the Weather Data Text box and <Type> the message text.  The message is displayed with the appropriate control characters.

5.
<Click> the Save button.  The Save Weather Message dialog box, illustrated below, is displayed with file name highlighted in the File name text box.  
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Figure 9‑17  Save Weather Message  Dialog Box

Table 9-13  Save Weather Message Dialog Box

	Label
	Component
	Purpose

	Save in
	Drop-down List Box
	Selects the desired directory the file is to be saved in.

	Windows Buttons 
	Shortcut Buttons 
	Manages drives, directories, files and views (Windows feature).

	Window
	Display Box
	Lists all folders and files contained in the directory listed in Save in.

	File name
	Text Box
	Displays the file name as typed or selected.

	Save as type
	Drop-down List Box
	Selects the desired file extension.

	Save
	Button
	Saves the file in the selected directory.


6.
If the Save Weather Message dialog box has the appropriate settings for Save in, File name, and Save as type, <Click> the Save button or modify the settings and <Click> the Save button.  The new message file is saved to the selected directory.

To Edit Existing Weather Data Messages:

1.
From the Edit pull-down menu, <Click> the Message menu option.  The Message cascading menu items are displayed.

2.
<Select> the Weather Data menu option.  The Weather Data Edit dialog box is displayed.  

3.
<Click> the Open button.  The Open Weather Message dialog box, illustrated below, is displayed.
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Figure 9‑18  Open Weather Message Dialog Box

Table 9-14  Open Weather Message Dialog Box Description

	Label
	Component
	Purpose

	Look in
	Scroll List
	Displays the list of directories

	Windows Buttons 
	Shortcut Buttons 
	Manages drives, directories, files and views (Windows feature).

	Window
	Display Box
	Lists all folders and files contained in the directory listed in Look in.

	File name
	Text Box
	Displays the file name as typed or selected.

	Files of type
	Scroll List
	Displays a list of file types and extensions.

	Open
	Button
	Opens the file in the selected directory.


4.
<Type> a message file name in the File name text box and <Click> the Open button.  The Open Weather Message dialog box is removed and the message is displayed in the Weather Message Edit dialog box.


OR

.
<Select> a file name from the list of message files and <Click> the Open button.  The file name and message text are displayed in the Weather Data Edit dialog box.

5.
To edit the weather message or file name, <Click> in the Weather Data Text box or the Name text box and update.  The text is modified.

6.
<Click> the Save button.  The Save Weather Message dialog box is displayed.

7.
<Select> the appropriate settings as necessary and <Click> the Save button.  The new message file is saved to the selected directory.

To Delete Weather Data Messages:

A message that is displayed in the Name text box of the Weather Data Edit dialog box can be deleted.

1.
<Click> the Delete button.  A Training Manager warning message is displayed.

2.
<Click> the Yes button to confirm the file deletion.

OR


<Click> the No button to cancel the file deletion.

9.2.3.3 Creating, Editing and Deleting Training Scripts

Flight and Weather Data messages that have been stored may be selected from a list and used in a training script.  Scripts are a sequential list of messages with a delta time offset from the initiation of the script.  Scripts can be created, named, edited, and saved via the Training Script Definition dialog box.  Scripts are stored on the NT Server.  The Training Server processes the messages just as if they were received over the NADIN II.
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Figure 9‑19  Training Script Definition Dialog Box

Table 9-15 Training Script Definition Dialog Box Description

	Label
	Component
	Purpose

	Messages
	List Box
	Displays list of messages available for use in the training script.

	Add
	Button
	Adds messages highlighted in the Messages list box to the training script identified in the Script Name text box.

	Remove
	Button
	Removes the selected messages from the selected Training Script.

	Remove All
	Button
	Removes all the messages from the training script.

	Training Script
	List Box
	Displays messages and injection times contained in the training script identified in the Script Name list box

	Messages
	Static Text
	Displays the number of messages contained in the current training script.

	Up
	Button
	Moves up the selected message in the current training script.

	Modify Time
	Button
	Changes the time of the selected message in the current training script.

	Down
	Button
	Moves down the selected message in the current training script.

	Script Name
	List Box
	Displays a list of stored training scripts.

Selected script is highlighted.

	Script Name
	Text Box
	Displays the name of the highlighted script.

	Save
	Button
	Stores a selected training script.

	Delete
	Button
	Removes a selected training script.


To Build and Store a Training Script:

1.
<Select> one or more messages from the Messages list box.

2
<Click> the Add-> button.   The Training Message Time Offset dialog box will be displayed.

3.
<Click> the Time Offset up or down arrows or directly type in the time to set the injection time for the message(s) currently being added.
4.
<Click> the Set button to confirm the time change.
5.
Repeat Steps 1 through 4 as desired.
NOTE:  The default value for the Time Offset text box is set to the last time offset used to add a message. 

6.
<Enter> a Script Name in the Script Name text box.  The Script name is displayed as typed.

7.
<Click> the Save button.  The new script is stored.
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Figure 9‑20  Training Message Time Offset

Table 9-16 Training Manager Time Offset Dialog Box Description

	Label
	Component
	Purpose

	Time Offset Instructions
	Static Text
	Displays and clarifies the purpose of this dialog.

	Time  Offset

 
	Text Box
	Selects the time offset that indicates the injection time of the message from the beginning of the script.

	
	Up and Down Arrows
	Changes the time in the edit box.

	Set
	Button
	Confirm the time in the TIME OFFSET text box.


To Edit the Time Offset for an Existing Script:

1.
<Double-Click> the message that needs a time offset change.  The Training Message time offset dialog box will be displayed.

2.
<Click> the Time Offset up or down arrows or directly type in the time to set the time for the message currently being added.  The numbers increase or decrease per the selected up or down arrow.

3.
<Click> the Set button to confirm the time change.

To Edit an Existing Training Script:

1.
<Select> the desired script from the Script Name list box.

2.
<Click> the Add->,<-Remove, or Remove All buttons as desired to modify script.  Messages are added or removed as desired.

3.
Modify the time offsets of the messages if desired 


<Double Click> on a message


OR

<Select> a message and <Click> the Modify Time button.

4.
Modify the script name in Script Name text box if desired.  The script name is displayed as typed.

5.
<Click> the Save button.  The modified script is saved.

If the user makes modifications and attempts to close the Training Script Definition dialog box without saving, a confirmation message is displayed requesting the user to save the updates or quit without saving.

To Delete a Training Script:

1.
<Select> the desired script from the Script Name list box.

2.
<Click> the Delete button.  A Training Manager warning message is displayed requesting a confirmation of the deletion.

3. <Click the Yes button to confirm the deletion.  The training script is removed from the list.

OR

<Click> the No button to cancel the deletion.  The training script is not deleted.

9.2.3.4 Deleting Sessions

The captured training sessions are displayed in the Training Sessions List dialog box illustrated below.  From this dialog box the user can select and delete a previously recorded session.
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Figure 9‑21  Training Sessions List Dialog box

Table 9-17.  Training Sessions List Dialog box Description

	Label
	Component
	Purpose

	Session ID
	Column
	Displays the name of the captured session.

	Start Time
	Column
	Displays the start time of the capture.

	Stop Time
	Column
	Displays the stop time of the capture.

	Number of Bytes
	Column
	The file size of the recorded session.

	Delete 
	Button
	Removes a captured session.

	Close
	Button
	Removes the dialog box.


To Delete a Training Session:

1.
<Select> the Session ID and <Click> the Delete button.  A Training Manager  confirmation message is displayed requesting a confirmation of the deletion.

2.
<Click> the Yes button to confirm the deletion.  The training session is removed from the list.


OR

3.
<Click> the No button to cancel the deletion.  The training session is not deleted.

9.2.4 Replaying Captured Data

The replay of captured data can begin at any time in the captured weather session.  However, the replay mode cannot be initiated while in the Edit or Capture modes.  Stored A/N weather data replays through the Training Server as if newly received.  During replay, the WGS continues to download current weather graphics data.

The training replay session begins when the Training Manager initiates a session replay and the user, at the AFSS workstation, selects the training mode on login.  During the active replay session, the Training Manager can insert training scripts and ad hoc messages.

A/N and graphical weather data are replayed via the Session Replay Request dialog box.
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Figure 9‑22  Session Replay Request Dialog Box

Table 9-18.  Session Replay Dialog Box Description

	Label
	Component
	Purpose

	Select a Session to Replay 
	Static Text
	Displays the action needed by the user.

	Session ID
	Column
	Displays the name of the captured session. 

	Start Time
	Column
	Displays the time the capture was started.

	Stop Time
	Column
	Displays the time the capture was stopped.

	Number of Bytes
	Column
	The file size of the recorded session.

	Select the Start Time
	Slide Bar and Up and Down Arrows
	Select the time for the replay.

	Ok
	Button
	Initiates the replay.


To Replay a Session:

1.
From the Training Manager window, <Click> the Replay menu option.  The Replay pull-down menu is displayed.  

2.
<Select> the Start menu option from the pull-down menu.  The Session Replay Request dialog box is displayed.

3.
<Select> a Session from the Select a Session to Replay list.

4.
<Select> a Training Sequence from the Select a Script to Replay pull-down list box.  Scripts can be started at any time during a replay.

5.
<Click> and <Hold> the slide bar to select the start time.  The start time is displayed.

6.
<Click> the up or down arrow to select the start time.  The start time is displayed.

7.
<Click> the OK button.  The Scenario Replay Status dialog box is displayed.

NOTE:  The user must be logged onto WINGS or WIND at an AFSS workstation in the training mode to receive the Training Manager’s scenarios.
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Figure 9‑23  Session Replay Status Dialog Box

Table 9-19.  Session Replay Status Dialog Box Description

	Label
	Component
	Purpose

	Date/Time
	Static Text
	Displays the date of the capture and the current time of the capture at that percentage into the captured session.

	%
	Static Text
	Percentage of the session capture that has currently been replayed.

	Play
	Button
	Restarts the replay after the scenario has been paused or stopped. 

	Pause
	Button
	Pauses the replay.

	Stop
	Button
	Stops the replay.

	Inject Message
	List Box
	Selects messages to inject.

	Inject
	Button
	Injects ad hoc messages into the training scenario.

	Script to Replay
	List Box
	Displays the set of scripts that can be chosen to inject messages into the session replay.

	Start
	Button
	Starts the particular script.

	Script List Box
	Scroll List
	Displays a summary list entry for each script that is currently being replayed.

	Script Name
	Column
	Displays the name of the script.

	Time Started
	Column
	Displays the current time when the script was actually started.

	Duration
	Column
	The length of time from when the first message is injected to the last message will be injected.


From the Training Manager, the user can pause, or stop a replay, start one or multiple scripts, and inject ad hoc training messages real time while the Session Replay Status dialog box is displayed.
To Start Scripts:

<Select> a script from the script list and <Click> the Start button.  The Script Name, Time Started, and Duration of the script will then appear down in the script list.

To start multiple scripts repeat the above procedure. Up to four scripts can be running simultaneously. When a script completes and less than four scripts are currently running then another script can be started during the course of the replay.
To Inject Messages:

<Select> a message from the message list and <Click> the Inject button.  Messages are injected into a session and displayed to a student at the AFSS workstation.

9.2.5 Simulating Multiple Site IDs

Simulating multiple site IDs for training purposes is accomplished by adding MBOs. The MBOs must be added during a session replay.  These added MBOs will only be available during the course of the session replay and will not be saved at the end of the session. 

To Add MBOs During Session Replay:

1.
From the Training Manager window, <Select> Replay>Start to display the Training Scenario Replay dialog box.

2.
<Select> a Session from the Select a Session to Replay list.

3.
<Select> a Training Sequence from the Select a Script to Replay pull-down list box.  Scripts can be started at any time during a replay.

4.
<Click> and <Hold> the slide bar to select the start time.  The start time is displayed.

5.
<Click> the up or down arrow to select the start time.  The start time is displayed.

6.
<Click> the OK button.  The Scenario Replay Status dialog box is displayed.

7.
Minimize the Training Manager application window.

8.
<Double-Click> the WINGS icon.

9.
<Click> the File menu.

10.
<Select> the Login menu option to display the Login dialog box.

11.
<Enter > the User ID (fdsadmin) and Password.  

12.
<Check> the Training Login checkbox.

13.
<Click> the OK button to attempt a login.

14.
<Select> Status>Facility Responsibility to display the Facility Responsibility Table.

15.
<Click> the Add Entry button to display the Facility Responsibility Entry Add dialog box.

16.
<Type> the desired Ident, and Address in the appropriate fields.

17.
<Select> Active for the Sparing State.

18.
<Select> MBO for the Facility Type.

<Repeat> steps 15-18 to add additional MBOs.

9.2.6 Maintenance Mode

Training Manager must be in Maintenance mode to permanently add users to the training database.  To initiate the maintenance mode, <Select> Maintenance>Start from the Training Manager window.

9.2.7 View Menu Option

The Training Manager’s View pull-down menu contains the following functions:

· Toolbar – Show or hide the toolbar.

· Status bar – Show or hide the status bar.

· Event Viewer – View and manage event dialogs.

9.2.7.1 The Toolbar

The Training Manager’s Toolbar can be turned on or off.  On is the default.  The toolbar, located at the top of the Training Manager Window, is a panel that contains a set of buttons designed to provide quick and easy access to specific menu options.

To Display or Hide the Toolbar:

<Select> View>Toolbar.  If a checkmark is displayed beside the option, the toolbar is displayed at the top of the Training Manager window.  Each time the Toolbar option is selected from the View pull-down menu the toolbar display will be toggled on or off.

9.2.7.2 The Status Bar

The Status Bar is an area at the bottom of the Training Manager’s main window that displays information about the current state of what is being viewed in the window.  The Status Bar provides descriptive messages about a selected menu or toolbar button.  The Status Bar is selected when there is a checkmark on the left side of the Status Bar menu option on the View pull-down menu.

To Display or Hide the Status Bar:

<Select> View>Status bar.  If a checkmark is displayed beside the option, the toolbar is displayed at the top of the Training Manager window.  Each time the Status bar option is selected from the View pull-down menu the toolbar display will be toggled on or off.

9.2.7.3 The Event Viewer 

The Event Log menu option provides the capability to view historical data on System, Security, or Application events.  The Event Log menu option opens the Event Viewer window, which is typically used for software maintenance by a user with maintenance capabilities.

To View the Event Log:

1. <Click> the Status menu.

2. <Select> the Event Log menu option to display the Event View window.

3. Utilize the menus within the Event Viewer window to change the data and appearance of the Event Log entries as necessary.

4. <Click> the Exit menu option from the Log menu to exit the Event Log and close the Log Viewing window.

NOTE: The Event Log is typically used for software maintenance by a user with maintenance capabilities.

9.2.8 Terminate the Training Manager

The Training Manager should be terminated if the system is placed in the weather backup mode.  

If a fail-over of the primary FDS occurs, the Training Server will automatically terminate.  Additionally, if a failure occurs with the Download Server NT application, the Training Manager will terminate, because Training Manager uses WIND, operating on NT Server 2. 

To Terminate Training Manager:

<Select> File>Exit in the Training Manager window.
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