Appendix B.  XE "Fault Isolation" \r "D2HBFault_Isolat1"   Fault Isolation

B.1   Overview

This appendix provides troubleshooting and fault isolation procedures for selected OASIS subsystems and components.

B.2   Fault Isolation

This section provides fault isolation information necessary to isolate problems or faulty components at the field level.  The appendix utilizes a three-level fault isolation philosophy for identifying problems and faulty LRUs within the OASIS site equipment as follows:

Top-Level Fault Isolation Flow Diagram - The OASIS Top-Level Fault Isolation Diagram, Figure B-1, is the starting point for diagnosing  all problems, and outlines the steps to be performed prior to calling the Harris Help Desk. 

System Data Flow Fault Isolation Diagrams – These diagrams are utilized for system data flow oriented faults, such as HWDS, UWDS or Flight data problems.  The Fault Isolation Diagrams  in this appendix begin with a general problem statement, such as “HWDS Data Problem” or “UWDS Data Problem”.  The checklists isolate faults to the component level or instruct the user to “Call the Harris Help Desk” for specific situations, such as antenna alignment problems, loss of the NADIN Network or loss of weather data XE "Weather Data"  to all sites.  Failures of this nature are typically external to OASIS and would require the site support personnel to contact the Harris Help Desk so that they can assist in coordinating the recovery.

Component Level Fault Isolation Checklists - These checklists will appear within the Testing/Verification XE "TESTING" \r "D2HBTESTING1"  section for each assembly or LRU.  These checklists will provide direction toward fault isolating the LRU from the cables, connections and surrounding LRUs, and attempt to determine the status of the LRU as operational or faulty.  This section will provide basic troubleshooting techniques for fault isolation and recommended corrective actions.

The Fault Isolation Diagrams and Checklists are designed to isolate to a specific LRU or to provide a list of items to be checked.  The detailed setup, configuration XE "Configuration"  and connection information for failed LRUs and procedural information for testing/and fault isolation of the system is provided in the following sections of this manual:

· Section 4.0, FDS Subsystem

· Section 5.0, VW Subsystem 

· Section 6.0, LCN Subsystem

· Section 7.0, AFSSWS Subsystem

NOTE:  The purpose of this appendix is to aid support personnel in fault isolation of system, component, and software failures.  Many of the problems isolated by following the procedures in this appendix will be corrected by AF technicians.
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Figure B‑1.  OASIS Top-Level Fault Isolation Diagram

Upon identifying a problem the support personnel should review the following Index of Observed Faults (Table B‑1) and locate the closest observed fault within the Table.  Upon locating the observed fault, you can review the indicated Fault Isolation Diagram or complete the corrective action, as specified. 

 Assumptions:

If a single Workstation is receiving a specific data type (HWDS, UWDS or Flight), then that data type is being received and processed properly by the site and the problem should be troubleshot as a workstation or network problem.

If a single workstation is unable to receive all data types (HWDS, UWDS or Flight), but other Workstations are OK, the problem should be troubleshot as a workstation problem.

Table B‑1.  Index of Observed Faults

	Observed Faults
	Corrective Action

	No current Graphical Weather Data XE "Weather Data"  (both HWDS & UWDS) to all Workstations (Weather Data Problem)
	#1 - If other Sites are not receiving Weather Data, call the Harris Help Desk.

#2 - If other Sites are receiving Weather Data, refer to the Weather Data Problem Fault Isolation Diagram.

	No current UWDS (Radar) Data to all Workstations, but Workstations are receiving HWDS.  (UWDS Data Problem)
	#1 - If other Sites are not receiving UWDS Data, call the Harris Help Desk.

#2 - If other Sites are receiving UWDS Data, refer to the UWDS Problem Fault Isolation Diagram.

	No current HWDS Data to all Workstations, but Workstations are receiving UWDS. (HWDS Data Problem)
	#1 - If other Sites are not receiving HWDS Data, call the Harris Help Desk.

#2 - If other Sites are receiving HWDS Data, refer to the HWDS Problem Fault Isolation Diagram.

	No current Flight Plan Data or A/N data to all Workstations (Flight Data Problem)
	#1 - If other Sites are not sending/receiving Flight Plan Data, call the Harris Help Desk.

#2 - If other Sites are sending/receiving Flight Plan Data, refer to the Flight Data Problem Fault Isolation Diagram.

	All Workstations are not receiving data or experiencing problems (Network Problem)
	Refer to the Network Problem Fault Isolation Diagram

	A single Workstation cannot receive data or is experiencing problems, but others are OK (Workstation Problem)
	Refer to the Workstation Problem Fault Isolation Diagram


 XE "Vendor Weather Subsystem"   Vendor Weather Subsystem

Figure B-2 illustrates the components of a typical CONUS Vendor Weather Subsystem (VWS).
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Figure B‑2. Typical CONUS XE "CONUS"   VW Subsystem

B.2.1  XE "TESTING" Weather Graphics Server Testing / Verification

Operational Verification and Testing on the WGS verifies that the overall WGS is operating correctly and receiving both HWDS and UWDS weather products and verifies that there are no unexpected alarms.  The user can also perform a restore from the Weather Backup Mode if necessary. 

Figures B-3 through B-7 illustrate the fault isolation process for the Vendor Weather Subsystems.
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Figure B‑3.  Weather Data XE "Weather Data"  Problem Fault Isolation XE "Fault Isolation" \r "D2HBFault_Isolat6"  Diagram.
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Figure B‑4.  UWDS Problem Fault Isolation Diagram (Sheet 1 of 2).
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Figure B‑5.  UWDS Problem Fault Isolation Diagram (Sheet 2 of 2).
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Figure B‑6.  HWDS Problem Fault Isolation Diagram (Sheet 1 of 2).

[image: image7.png]From page
1of2

EF Data
Indicators
OK?

YES

v

Suspect the HWDS Cable
between the EF Data
Receiver and the WGS.
Check the connections or
remove & replace the cable.

At the NT Server, use the
tail -f get command to ensure
that the WGS is receiving
HWDS Data.

WGS
Receiving
HWDS Data?

NO

v

Suspect the PT Serial
Inteface Card within the
WGS. Remove &
replace the PT Card.

NO

v

Reboot the EF Data
Receiver.

!

Check that the Power, Carrier
Detect & Low Noise indicators
on the EF Data Receiver
are ON, and that the Fault
indicator is OFF.

EF Data Receiver
Indicators
OK?

YES
A4

Suspect the I/F Cable
between the WGS and
EF Data Receivers. Check the
connections or remove &
replace the I/F Cable.

WGS Receiving
HWDS Data?

YES

4

Verify System
Operations

Y

YES

WGS
Receiving
HWDS Data?

NO—p the EF Data Receiver.

| Go to the Fault Isolation
Checklist for the Antenna
NO—, Assembly in the VWS Section
1 of the SMM.

Suspect a problem with

Call the Harris Help —> —
Desk prior to
removing & replacing
the Receiver.
CALL
HARRIS HELP DESK

1-877 373-0110

Fault Isolation
Complete

NO—Pp>|

CALL
HARRIS HELP DESK 11/10/02
1-877 373-0110 1608-162




Figure B‑7.  HWDS Problem Fault Isolation Diagram (Sheet 2 of 2).

To Telnet to the WGS from the Backup NT Server:

 To access the WGS, it is necessary to Telnet from the Backup NT Server.

1.
At the Backup NT Server (NT 2), <Select> Start>Programs>Accessories>Command Prompt to open a DOS window.

2.
At the Command Prompt, <Type>Telnet(xx.xxx.xxx.15 (where xx.xxx.xxx is equal to the Site IP address for your location and 15 is equal to the WGS IP Address)..

3.
At the login prompt, <Type> the appropriate non-privileged Username and Password for the WGS.

4.
At the prompt, <Type> su(–(Username (privileged) followed by the Password when prompted.  Upon successful login, the WGS should respond with the # prompt. 

5.
When finished, <Type> exit at the prompt and <Press> the Enter key to log off of the privileged user account.

6.
<Type> exit at the prompt and <Press> the Enter key to log off of the non-privileged user account.

7.
<Click> the X button to close the Command Prompt window.

B.2.1.1  XE "Operational Verification" \r "D2HBOperational_11" Operational Verification of the WGS:

The following procedure will verify that the WGS is receiving both HWDS and UWDS graphical weather products.   The user must be logged on to the WGS at the Administrator (Admin) level.

1. At the prompt <Type> rlog and <Press> Enter to navigate to the directory /data/logfiles/recvprod. 

2. <Type> ls and <Press> Enter to view the files within the /recvprod directory and ensure that the files get, nxrhndl and moshndl appear within the directory.

3. To view the Server receiving HWDS data, <Type> tail(-f(get and <Press> Enter.  The system should respond by displaying a list of incoming weather products that are being updated every few seconds.

4. To exit this mode, <Press> the Ctrl and C keys simultaneously. 

5. To view the Server receiving UWDS data, <Type> tail(-f(nxrhndl and <Press> Enter.  The system should display a list of incoming radar products that is being updated every few seconds.

6. To exit this mode, <Press> the Ctrl and C keys simultaneously. 

7. To view the Server receiving UWDS (mosiac) data, <Type> tail(-f(moshndl and <Press> Enter.  The system should display a list of incoming radar mosaic products.

NOTE:  Radar mosaics come in on a cycle of approximately one every 5 minutes.

8. To exit this mode, <Press> the Ctrl and C keys simultaneously.

9. Logoff and then close the Window for the WGS.

B.2.2 
 XE "Unisys Gateway" \r "D2HBUnisys_Gatew11" Unisys Gateway Operational Verification
To verify that the Unisys Gateway PC is operating correctly, monitor the Gateway to ensure that the unit is receiving, processing, and outputting data.  This procedure can be run without interrupting normal operations.

B.2.2.1 To Monitor that the Gateway PC is Receiving Data

To verify that the Unisys Gateway PC is operating correctly, monitor the Gateway’s WeatherMax Gateway Screen Saver.  There are two different versions of the Screen Saver, as shown in the following figures.

Screen Saver Type 1
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Figure B‑8  WeatherMax Gateway Screen Saver1
A loss of input data to the Gateway will result in the following conditions:

· Loss of the Throughput Data displayed on the WeatherMax Gateway Screen Saver.

· Throughput (Tput) incrementing to zero.

· Average Throughput (AvgT) incrementing to zero.

A loss of the LAN path between the Gateway and the Weather Graphics Server will result in the following conditions:

· The LAN/WxData’s “Free” column will start to decrement.

· When LAN/WxData’s “Free” column increments to approximately 55%, the LAN/WxData display will change from white to yellow.

· When LAN/WxData’s “Free” column increments to approximately 20%, the LAN/WxData display will change from yellow to red.

· After approximately 10 minutes, the LAN/WxData’s “State” column will change from Active (A) to Degraded (D).

Screen Saver Type 2
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Figure B‑9  WeatherMax Gateway Screen Saver2

A loss of input data to the Gateway will result in the following conditions:

· In the Gateway Status area of the Screen Saver, the Throughput bps displays as zero.

A loss of the LAN path between the Gateway and the Weather Graphics Server will result in the following conditions:

· In the User Status area the Low Buf column will start to decrement.  When it reaches zero, it immediately displays as 100% and remains there.

After approximately 10 minutes, in the User Status area the Status column will change from active (CONN) to Degraded (DISC).
B.2.2.2 Unisys Gateway Fault Isolation  XE "Fault Isolation"  Checklist

· If the Unisys Gateway PC is experiencing any problems either receiving or sending data, reboot the Gateway by shutting off the power and turning it back on.

· If the operational verification fails, check to ensure that the Comstream Receiver has the Power, Sync and Enable indicators lit green.  If the Comstream indicators are OK but the Gateway is not receiving data, suspect the Unisys Gateway (which includes a GCOM Cable).

· If the Gateway is receiving data, but UWDS (radar) products are not being received at the Weather Server, use the ping(srvr command from the NT Server to verify the 10Base-T ethernet connections between the two.  If the ping command reports the amount of bytes transferred, the ethernet NIC within the Gateway and the 10Base-t Cable to the WGS are operational.  Suspect the WGS has an ingesting problem and reboot the WGS.

· If the ping(srvr command was unsuccessful (0 bytes transferred), suspect the 10Base-T crossover cable between the Gateway and the WGS.  Re-terminate, or replace the crossover cable.

  Flight Data Server Subsystem Testing / Verification

B.2.3  XE "Operational Verification" \r "D2HBOperational_17" Operational Verification

The figure below illustrates the data flow in a typical FDS system.  The following procedures explain how to verify that all essential FDS software processes are running and how to perform FDS fault isolation.
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Figure B‑10.  Typical FDS Data Flow Diagram

B.2.3.1 To Verify That the FDS Software Processes XE "Software Processes" \r "D2HBSoftware_Pro17"  Are Running:

This procedure is used when FDS-1 is operating as the primary Flight Data Server,  and requires the user to connect to FDS-1 through the Backup NT Server using the HyperTerminal software.

1.
Connect the Backup NT Server to FDS-1 using the Maintenance XE "Maintenance" \r "D2HBMaintenance17"  Patch Panel.

2.
At the Windows Desktop on NT Server-1, <Double-Click> the HyperTerminal icon.

3.
<Double-Click> the Flight Data Server.ht icon to access the HyperTerminal window.

4.
Within HyperTerminal window, <Press> the Enter key to display the “Console Login:” prompt.

5.
At the “Console Login:” prompt, <Type> the appropriate Username and Password to login to the FDS.  The FDS should respond with the “fds1xxx” prompt (where xxx is equal to the Site ID).

6.
At the “fds1xxx” prompt, <Type> cmviewcl and <Press> the Enter key to display the status on both Servers and the cluster.  The line that begins with “PACKAGE” and ends with “NODE” indicates which Server has the primary software enabled, as shown in the following example: 

	CLUSTER
	STATUS
	
	
	

	cluster 1
	up
	
	
	

	
	
	
	
	

	NODE
	STATUS
	STATE
	
	

	fds1xxx
	up
	running
	
	

	
	
	
	
	

	PACKAGE
	STATUS
	STATE
	AUTO-RUN
	NODE

	fds_pkg
	up
	running
	enabled
	fds1xxx

	
	
	
	
	

	NODE
	STATUS
	STATE
	
	

	fds2xxx
	up
	running
	
	

	
	
	
	
	

	PACKAGE
	STATUS
	STATE
	AUTO-RUN
	NODE

	tfds_pkg
	up
	running
	disabled
	fds2xxx

	
	
	
	
	


7.
Check the Status Display to ensure that FDS-1 is the primary Server (the Server listed as “enabled” and running the “fds_pkg”).  Also check to ensure that the node “fds2xxx” has a status of “up”.

8.
At the “fds1xxx” prompt, <Type> ps(-usrm and <Press> the Enter key to view the list of software processes running on the FDS.  The primary FDS should respond with a list of 15 processes as shown in the following example:

	PID
	TTY
	TIME
	COMMAND

	###
	?
	#:##
	srm

	###
	?
	#:##
	dbm

	###
	?
	#:##
	wxu

	###
	?
	#:##
	fds_inetd

	###
	?
	#:##
	upd

	###
	?
	#:##
	w2_dq

	###
	?
	#:##
	sched_server

	###
	?
	#:##
	w2_int

	###
	?
	#:##
	scrman_stats

	###
	?
	#:##
	wmsc_read

	###
	?
	#:##
	gw_int

	###
	?
	#:##
	wx_client

	###
	?
	#:##
	n2_read

	###
	?
	#:##
	gw_dq

	###
	?
	#:##
	fpbackup


9.
Resume normal operations.

10.
When verifying that NADIN II XE "NADIN II"  is operational, check the list to ensure that “gw_int” appears within the list.

11.
If the 15 software processes are not running on the primary FDS, or if “gw_int” does not appear within the list, it may be necessary to halt the cluster, shutdown XE "Shutdown"  and reboot the suspect FDS, then restart the cluster per the Fault Isolation XE "Fault Isolation"  Section, below. 

B.2.3.2 FDS Fault Isolation

Figures B-11 and B-12 diagram the FDS fault isolation process.
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Figure B‑11.  Flight Data Problem Fault Isolation XE "Fault Isolation" \r "D2HBFault_Isolat15"  Diagram (Sheet 1 of 2).
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Figure B‑12.  Flight Data Problem Fault Isolation Diagram (Sheet 2 of 2)  File Data Server Subsystem

If an FDS fails the operational verification (does not display the 15 processes), is indicated as bad by HP OpenView XE "HP OpenView" \r "D2HBHP_OpenView18"  (red icon), or if the HACC is running in a degraded state (fail-over mode), perform the following actions in an attempt to restore the unit to normal operations:

· If the problems are isolated to the backup FDS (FDS-2), halt and restart FDS-2 only, thus causing minimal impact to WINGS users.

· If experiencing problems with the primary Server or the performance of the HACC in general, the best option is to halt and then restart the entire cluster to return it to normal operations.

· If halting and restarting the cluster does not restore the 15 processes, it will be necessary to halt the cluster and power-down both Servers to reboot the entire system.

· If an FDS fails HP OpenView by displaying a red icon or if a LAN problem is suspected, use the Backup NT Server to ping both FDSs to verify connectivity to the LCN.

NOTE:  The boot process takes approximately five minutes.  During the boot process, maintenance significant information concerning the system status such as memory status, network connections, and software processes are scrolled to the LCD during the first minute of the boot process, then to the screen (if logged-in using the Maintenance Position XE "Maintenance Position" ).

B.3 
Local Communications Network Subsystem

The figure below illustrates the typical LCN connections.  Figure B-14 diagrams the steps to  perform fault isolation for Network problems.
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Figure B‑13.  Typical LCN Connection Diagram
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Figure B‑14.  Network Problem Fault Isolation XE "Fault Isolation" \r "D2HBFault_Isolat20"  Diagram

B.3.1  XE "Ethernet Switch"  Fault Isolation of Ethernet Switches

	  See Another Document
	To verify the operation of individual ports, the device connected to that port must be “pinged”.  Use the Backup NT Server in conjunction with the Interconnect Diagram within the Site Drawing Package to verify the operation of the Ethernet Switch.


To Ping the Ethernet Switch:

1. At NT-2 server, use the Start button and <Select> Start>Programs>Accessories>Command Prompt to open a DOS Window.

2. At the “C:\>” prompt, <Type> ping(xxx.xxx.xx.xx and <Press> Enter where the x’s represents the IP Address for the Ethernet Switch under test.  Appendix A provides the IP addresses XE "IP Addresses"  for all the network devices.

If the Ethernet Port and the connection to the Backup NT Server are operational, the system should respond several times with the correct IP Address and the number of bytes transferred. 

If the system responds with a “timeout”, recheck the IP address and the network connections.

3. To test all the Ethernet Switches, <Type> ping(xxx.xxx.xx.xx and <Press> Enter where the x’s represent the IP Address for each Ethernet Switch under test.

4. Upon the completion of using the DOS window,  <Type> exit at the “C:\>” prompt and <Press> Enter to return to the Windows Desktop.

B.3.2  NT Server Assembly

B.3.2.1  XE "TESTING" Testing/Verification

NOTE:  For the NADIN II Interface to operate, the OWLG software must be running on the primary NT Server.  The OWLG dialog box may be opened on the Windows Desktop or minimized to the Task Bar.  Closing the OWLG dialog box, logging off of the primary NT Server, or shutting down will stop the OWLG software and will kill the OASIS interface to NADIN II for the entire AFSS  XE "Operational Verification" 
To verify that the NT domain is 100% operational, both Server names must appear within the Net View list and the AFSSWSs must be capable of displaying the Windows desktop.  Only the primary NT Server must be checked to verify that the NADIN II Interface is operational.

If specialists at an AFSSWS are able to receive up-to-date Notices to Airmen (NOTAMs) or Pilot Weather Reports (PIREPs), or if General Facility Messages (TALLYs) can be sent, the NADIN II interface is considered operational.  This test can be run from an AFSSWS or the Backup NT Server. The default is the Backup NT Server, also called the Maintenance XE "Maintenance"  Position.

To Verify That the NT Domain is Operational:

1. At the Windows Desktop, use the Start button to <Select> Start>Programs>Accessories>Command Prompt and open a DOS window.

2. At the  prompt, <Type> net(view and <Press> Enter to list all the active Servers within the NT domain.  At a minimum, the Server should display:

“\\NTSVR1”

“\\NTSVR2”

3. At the prompt, <Type> net(view(\\ntsvr1 and <Press> Enter to list all the file shares and printer shares on the queried Server. NT-1  should respond with the list of file shares and printer shares as follows:

“CPTR4550N
Print”

“CPTR4600

Print”

“MPRINTER
Print”

"MPTR2300
Print"


“NETLOGON
Disk”

“OASIS

Disk”
"SYSVOL

Disk"
4.
At the prompt, <Type> net(view(\\ntsvr2 to list all the file shares and printer shares on the queried Server.  NT-2 should respond with the following list of file shares and printer shares:

“CPTR4550
Print”

“CPTR4600
Print”

“MPRINTER
Print”

“NETLOGON
Disk”

"MPTR2300
Print"

“OASIS

Disk”

"SYSVOL
Disk"

“TMGR
Disk”

4. When finished,  <Click> the X to close the DOS window and return to the Windows Desktop.

5. To ultimately verify that the NT domain is operational, go to an AFSSWS and login to Windows.  If the AFSSWS boots up and displays the Windows Desktop, the NT domain is operational.

To Send a Test General Facility Message:

Verify the NADIN II Interface by sending a test General Facility Message and watching the message leave the Suspense List, which indicates that the message was transferred to the OASIS Wide Area Network (WAN).

1. At NT-2 Server, <Double-Click> the WINGS icon to start the WINGS application, and <Login> using the appropriate Username and Password.

2. Within the WINGS application, <Click> the Lists pull-down menu and <Select> Suspense to display the Suspense List dialog box shown in the figure below.
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Figure B‑15  Suspense List Dialog Box

3. Open a second dialog box within WINGS by <Clicking> the Transmit Data pull-down menu and <Selecting> General Facility Message to display the General Facility Message dialog box, shown in the figure below.
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Figure B‑16.  General Facility Message Dialog Box

4. Within the General Facility Message dialog box, <Click> in the Facility Addresses field and <Type> *xxx where xxx is a valid Site ID of an operational AFSS.  Example:  “*sea” (for the Seattle AFSS).

5. <Click> within the General Facility Message field and <Type> an explanatory text message such as ”xxx NADIN II Test” (where xxx is your AFSS Site ID).

6. <Click> within the Transmit Time field and <Type> a transmit time of approximately one minute ahead of the system clock located on the right side WINGS Status Bar.

7. When the time is set one minute into the future, <Click> the Transmit button on the General Facility Message dialog box and <Click> OK within the WINGS message box to confirm the action.

8. View the Suspense List to ensure that the General Facility Message appears on the Suspense List until the preset transmit time.  At the preset transmit time the General Facility Message should automatically be removed from Suspense List, indicating that the General Facility Message was successfully transmitted to the OASIS WAN.

B.3.3  To Verify That the NADIN II is Operational:

The following three independent functions must be operating and available within OASIS to ensure that the NADIN II Interface is operational and has established an X.25 connection to the OASIS Wide Area Network:

· The primary FDS (typically FDS-1) software must be operational and processing NADIN II messages, such as flight transactions or General Facility Messages.

· The OWLG software must be running on the primary NT Server.

· The X.25 Router Card must be operational and router services must be started on the primary NT Server.

NOTE:  For the NADIN II Interface to operate, the OWLG software must be running on the primary NT Server.  The OWLG dialog box may be opened on the Windows Desktop or minimized to the Task Bar.  Closing the OWGL dialog box or logging off of the primary NT Server will stop the OWLG software and will kill the OASIS interface to NADIN II.

	  See Another Document
	The following three procedures are used to verify that the NADIN II resources are available and operating.  If one or more of the resources are down, refer to the System Maintenance XE "Maintenance"  Manual, Section 10, External Interfaces, for the restart procedures.


To Verify That the FDS Software Processes XE "Software Processes"  Are Running:

This procedure assumes that FDS-1 is operating as the primary Flight Data Server, and requires the user to connect to FDS-1 through the Backup NT Server using the HyperTerminal software.

1.
Connect the Backup NT Server to FDS-1 using the Patch Panel.

2.
At the Windows Desktop, <Double-Click> the HyperTerminal icon to display the Flight Data Server HyperTerminal window.

3.
Within the Flight Data Server HyperTerminal window, <Press> the Enter key to display the “Console Login:” prompt.

4.
At the “Console Login:” prompt, <Type> the appropriate Username and Password to login to FDS-1.  The FDS should respond with the “fds1xxx” prompt (where xxx is equal to the Site ID).

5.
At the “fds1xxx” prompt, <Type> ps(-usrm and <Press> the Enter key to view the list of software processes running on the FDS.  The primary FDS should respond with a list of approximately 15 processes as shown in the following example:

	PID
	TTY
	TIME
	COMMAND

	###
	?
	#:##
	srm

	###
	?
	#:##
	dbm

	###
	?
	#:##
	wxu

	###
	?
	#:##
	fds_inetd

	###
	?
	#:##
	upd

	###
	?
	#:##
	w2_dq

	###
	?
	#:##
	sched_server

	###
	?
	#:##
	w2_int

	###
	?
	#:##
	scrman_stats

	###
	?
	#:##
	wmsc_read

	###
	?
	#:##
	gw_int

	###
	?
	#:##
	wx_client

	###
	?
	#:##
	n2_read

	###
	?
	#:##
	gw_dq

	###
	?
	#:##
	fpbackup


6.
When verifying that NADIN II is operational, check the list to ensure that “gw_int” appears within the list.

7.
At the “fds1xxx” prompt, <Type> exit and <Press> the Enter key to end the UNIX session and logoff XE "Logoff"   the FDS.  When logged off, the FDS should respond with the “Console Login:” prompt.

	     [image: image17.png]



	8.    When the “Console Login:” prompt is displayed, the user may <Click> the X button to close the Flight Data Server HyperTerminal window, thus closing the hyper-terminal connection to the FDS.



The Backup NT Server should return to the Windows Desktop and be available for normal operations.

To Verify That X.25 Router Services Are Started:

This procedure verifies that the X.25 Router Card within the NT Server is operational and that Services are started.  This procedure is run from the Windows Desktop of the primary NT Server.

1. Use the Start button and <Select> Start>Programs>Administrative Tools>Services to display the Services dialog box, illustrated below.
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Figure B‑17  Services Dialog Box

2. Within the Services dialog box, <View> the Name list to ensure that “EICON Cards” appears and that the status is listed as “Started”.

3. <Click> the X button to close the Services dialog box and return to the Windows Desktop

To Verify That the OWLG Software is Operational:

This procedure contains the following two actions:

· To verify that the OWLG software is started on the primary NT Server.

· To verify that the primary FDS is communicating with the OWLG software (also called the Message Router) running on the primary NT Server, and that an X.25 connection has been established with the OASIS WAN.

This procedure assumes that FDS-1 is operating as the primary Flight Data Server. XE "Flight Data Server"  

1.  At the primary NT Server (NT Server 1), perform a visual check to verify that the OWLG software is started.  On the Windows Desktop, ensure that the OWLG window (illustrated below) is either open or minimized on the Taskbar. 

2.  If the OWLG window is minimized <Click> the OWLG window on the Taskbar to open.

3.
Verify that the “Overall WAN Status” displays the word UP. 
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Figure B‑18  OWLG window

4.
After verifying that the OWLG software is started the user can again minimize the OWLG window.

CAUTION:  Never log off from the NT Servers.  One of the functions of the NT Servers is to support the NADIN II interface.  If the NT Servers are logged off, NADIN II messaging will be inoperable for the AFSSWS users.

B.4  XE "TESTING" \r "D2HBTESTING35"   Workstation Subsystem Testing/Verification

B.4.1  XE "Operational Verification" Operational Verification

Under normal operating conditions an AFSS Workstation must be:

· connected to the NT Domain, 

· capable of accessing the FDS XE "Accessing the FDS" 

 XE "FDS Access"  software to run WINGS

· capable of connecting to the WGS to display weather products

The ability to display the Windows Desktop on an AFSS Workstation indicates that the NT Domain is operational.  Upon a valid login to the WINGS application, the WINGS Toolbar becomes active (not grayed out) indicating that the user has successfully logged in to the FDS software and that the AFSS Workstation is communicating with the primary FDS.  The ability to display weather products using WIND indicates that the connection to the WGS is active and that the Download XE "Download" \r "D2HBDownload35"  software is operating.  

Figures B-19 and B-20 illustrate the Workstation fault isolation process.
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Figure B‑19  AFSS Workstation XE "AFSS Workstation" \r "D2HBAFSS_Worksta33"  Problem Fault Isolation XE "Fault Isolation" \r "D2HBFault_Isolat33"  Diagram (Sheet 1 of 2)
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Figure B‑20  AFSS Workstation Problem Fault Isolation Diagram (Sheet 2 of 2)

To Identify an NT User Logged On an AFSS Workstation:

1. Simultaneously <Press> Ctrl+Alt+Delete.  A “Windows Security” window will be displayed.

The first line of logon XE "Logon"  information contains:

<full username> is logged on as <short username>

2. <Click> the Cancel button to return to the normal display.

To Verify the Operations of an AFSS Workstation:

1.
At the AFSSWS, <Login> to Windows or <Minimize> the WIND and WINGS applications as necessary to display the Windows Desktop.  If the Windows Desktop can be displayed, the connection to the NT Domain is operational.

2.
At the Windows Desktop, <Double-Click> the WINGS icon to open the WINGS application and logon to WINGS using a valid Username and Password.

3.
At the Functional Assignment XE "Functional Assignment"  Select window, <Select> the appropriate Functional Assignment from the list and <Click> the OK button.

4.
Observe that the WINGS window is displayed and that the WINGS Toolbar becomes active (colored).  The active WINGS Toolbar indicates that the user has successfully logged in to the FDS software and that the AFSS Workstation is communicating with the primary FDS.

5.
<Minimize> or <Close> the WINGS window as necessary to return to the Windows Desktop.

6.
At the Windows Desktop,  <Double-Click> the WIND icon to open the WIND application and display the Weather Graphics window.

7.
At the Weather Graphics window, <Click> the File menu and <Select> Current Products XE "Current Products" \r "D2HBCurrent_Prod35"  to display the Current Products dialog box, shown in the following figure.

8.
Within the Current Products dialog box, <Click> an appropriate Class and Clipboard to select a satellite or radar product for display.  <Press> the Display button to open a Product window and display a weather graphic product.

9.
Check the Title Bar of the Product window and ensure that the displayed weather product is current (not more that 20 minutes old).

10.
At the Weather Graphics window, <Click> the File menu and <Select> Exit to close the WIND application.  The ability to display current weather products using WIND indicates that the connection to the WGS is active and that the Download software is operating.
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Figure B‑21  Current Products Dialog Box

B.4.2  XE "Fault Isolation" Testing/Fault Isolation

To Verify That the NT Domain is Operational:

1.
At the AFSS Workstation, <Exit> or <Minimize> the WINGS window as necessary to access the Windows Desktop.

2.
From the Windows Desktop use the Start button and <Select> Start>Programs>Accessories>Command Prompt to open a DOS window.

3.
At the  “C:\>” prompt, <Type> net(view and <Press> Enter to list all the active Servers within the NT domain.  At a minimum, the Server should display:

“\\NTSVR1”

“\\NTSVR2”


The above display indicates that the NT Domain is operation.

To Verify the Network Connectivity:

To verify connectivity through the LCN, “ping” the Weather Graphics Server from an AFSSWS.

1.
At the AFSS Workstation, <Exit> or <Minimize> the WINGS window as necessary to access the Windows Desktop.

2.
Using the Start button, <Select> Start>Programs>Accessories>Command Prompt to open a DOS Window.

3.
At the “C:\>” prompt, <Type> ping(xxx.xxx.xx.15 and <Press> Enter where the x’s represents the Site ID portion of the IP Address for the WGS.


The system should reply several times with the correct IP Address and the number of bytes transferred.  If the system responds with a “timeout”, recheck the IP Address and the Network connections.

To Verify That Download Client is Receiving Weather Products:

1.
Log on to WINGS.

2.
At the Windows Desktop,  <Double-Click> the WIND icon to open the WIND application and display the Weather Graphics window.

3.
At the Weather Graphics window, <Click> the File menu and <Select>  Current Products to display the Current Products dialog box.

4.
Within the Current Products dialog box, <Click> an appropriate Class and Clipboard to select a satellite or radar product for display.  <Click> the Display button to open a Product window and display a weather graphic product.

5.
Once a Product Window is open, <Click> the DownloadClnt button on the Windows Task Bar to restore the Download Client dialog box shown in the figure below.  Ensure that the Connection Status shows the IP Address of the WGS (xxx.xxx.xx.15 where the “x”s represent the Site address) and that the Product Class / Clipboard changes when a different product is displayed.
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Figure B‑22  Download Client Dialog Box
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